Power Valve Motor

Dodgy Kips motor? CDI? battery? diode? reg/rect? its all gobbledygook to me but some people understand it ask tham a question here
Post Reply
wilsonzx6
lurker
Posts: 4
Joined: Tue Jan 19, 2016 10:55 pm

Power Valve Motor

Post by wilsonzx6 » Tue Nov 29, 2016 3:33 pm

Hi

I have rebuild my KR1s; the power valve motor is occilating continuously left and right rather than re-setting the power valves when the ignition is turned on. This happens even when cables are disconnected so its nothing to do with mechanism

The rev counter is also not working; does anyone know if the power valve motor operation is dependant on the rev counter operating.

Thanks for help

User avatar
bozbridge
Oil Injector
Posts: 507
Joined: Thu Dec 12, 2013 9:58 pm
Location: York

Re: Power Valve Motor

Post by bozbridge » Fri Dec 30, 2016 8:00 pm

Could be a lot of things but there's a few basics to check. First, take the PV motor off its' bracket and look at the black unit (the "pot") that's secured by 2 screw and has adjustable slots. Mark its' position, remove the screws and remove it. Once off there's a shaft in the centre of it, give it a few full turns in either direction then refit it.

If that doesn't work, use a avo to check continuity of every wire through the loom from PV motor connectors to CDI connectors.

From you mentioning the rev counter not working it's quite likely the CDI is faulty, often caused by a faulty reg/rec or running the bike with a duff/missing battery and the end result being the too high voltage reaching the CDI unit. If you get a new CDI to test that, fit the new one then do a PV test first without starting the engine, if the motor works ok make sure you're battery & charging system are good before you fire it up otherwise you might just blow the new CDI as well!.

PS where abouts are you? you might be near someone who has spare bits to lend & test

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest