Kr1 1989 misfire issue

Dodgy Kips motor? CDI? battery? diode? reg/rect? its all gobbledygook to me but some people understand it ask tham a question here
Post Reply
Bailey9814
lurker
Posts: 2
Joined: Tue May 11, 2021 8:36 pm

Kr1 1989 misfire issue

Post by Bailey9814 » Sat May 15, 2021 12:15 pm

Hi so my issue is the bike will be completely fine low end revs then high end if you light bring the revs up to high revs it will also be fine but under load full throttle at around 7k it will begin to splutter/misfire then when you let off it will drop to 1 cylinder then fire back up once the revs have dropped and it’s not under as much load. I have tried changing plugs, tried 3 other coils, wiring looks okay, spark plug caps look okay and carbs were cleaned not to long ago but I have a carb rebuild kit so I’ll fit that and possibly look at the reeds. If anyone has an idea on this I would much appreciate the help thank you

krm
Newbie
Posts: 23
Joined: Sun Jun 29, 2014 3:50 pm

Re: Kr1 1989 misfire issue

Post by krm » Fri May 21, 2021 3:06 pm

Sounds a bit like a fuel flow issue, if it's okay partial throttle. Maybe check the tap and the vacuum system works correctly and re-clean the carbs If it's been sat more than 1 month.
If you have a multimeter, worth checking stator and other ignition components too like pick up coils,plug caps etc, you can trim the HT lead down a few mm if it's corroded.

Bailey9814
lurker
Posts: 2
Joined: Tue May 11, 2021 8:36 pm

Re: Kr1 1989 misfire issue

Post by Bailey9814 » Mon May 31, 2021 2:03 pm

I have now resolved the issue it seemed to be a bad earth off the coil

Post Reply